Kinook Software Forums

Kinook Software Forums (https://www.kinook.com/Forum/index.php)
-   [VBP] General Discussion (https://www.kinook.com/Forum/forumdisplay.php?f=2)
-   -   Wscript.Echo not working (https://www.kinook.com/Forum/showthread.php?t=5755)

teognost 11-23-2021 12:24 PM

Wscript.Echo not working
 
Hi
I have a Run Script step (VBScript) inside my Visual Build project which contains:
Wscript.Echo "Test message"
When i start it in Visual Build the message is shown in the log.
But when I run it command line like this:
"c:\Program Files\VisBuildPro9\VisBuildCmd.exe" /b "c:\Program Files\VisBuildPro9\Test.bld"
the message is now shown in the log.
Any idea why and how can I make it visible ?

kinook 11-23-2021 08:24 PM

1 Attachment(s)
It works in my tests. Using the attached project, and building with

"C:\Program Files\VisBuildPro10\VisBuildCmd.exe" D:\temp\test.bld

it outputs

11/23/2021 7:22:54 PM: Starting Build: 'D:\temp\test.bld'
11/23/2021 7:22:54 PM: Building project step 1 - Project steps...
11/23/2021 7:22:54 PM: Building project step 2 - Run Script...
Test message
11/23/2021 7:22:54 PM: Build successfully completed (elapsed = 00:00:00).

Please send the info from

https://www.kinook.com/Forum/showthread.php?t=3044

teognost 11-24-2021 09:46 AM

I cannot open\run the test project as I have VisBuildCmd (x64), Version 9.7.0.1 and yours is a newer version.
Would be possible to give me the same test project but version 9.7?

teognost 11-24-2021 11:34 AM

I tried my test project on other machine -wscript.echo worked ,i had the test message in the log.Any idea why on that specific machine the command does not work?Could be some Visual Build setting causing this issue?

kinook 11-24-2021 01:23 PM

Open the .bld file in a text editor and change the version to 9.

I don't know, send the info in the link above and we'll see.

teognost 11-24-2021 02:07 PM

I ran it and the echo did not work:
:\Program Files\VisBuildPro9>"c:\Program Files\VisBuildPro9\VisBuildCmd.exe" "c:\Program Files\VisBuildPro9\Test.bld"

VisBuildCmd (x64), Version 9.7.0.1

11/24/2021 9:04:54 PM: Starting Build: 'c:\Program Files\VisBuildPro9\Test.bld'
11/24/2021 9:04:54 PM: Building project step 'Project steps'...
11/24/2021 9:04:54 PM: Building project step 'Run Script'...
11/24/2021 9:04:54 PM: Build successfully completed (elapsed = 00:00:00).

The link you provided is for Ultra Recall,could you please tell me which one is for Visual Build...

teognost 11-24-2021 02:08 PM

I found it:
https://www.kinook.com/Forum/showthread.php?t=3044
I will send the info required here

kinook 11-25-2021 08:50 PM

In the .config file, set the LogLevel to 3, or in the UI, set Tools | Application Options | Logging (More) | Log Level to Detailed.

teognost 11-26-2021 05:45 AM

Thanks,this change in log level to detailed solved the issue


All times are GMT -5. The time now is 09:42 AM.


Copyright 1999-2022 Kinook Software, Inc.