Kinook Software Forums

Kinook Software Forums (http://www.kinook.com/Forum/index.php)
-   [VBP] Third Party Tools (http://www.kinook.com/Forum/forumdisplay.php?f=3)
-   -   December 10 update breaks Oracle action (http://www.kinook.com/Forum/showthread.php?t=5550)

mevans 01-08-2019 02:24 PM

December 10 update breaks Oracle action
 
I was just at a good point yesterday to update Visual Build 9.7 to the December 10, 2018 revision. Today I tried running a script that does some Run Oracle Script actions. Visual Build just hung. I tried many times. I was running 9.7 prior to this and it worked fine. In fact, went back to a version of 9.7 that I had from September and installed it (I had to uninstall first because the installer wouldn't install older components). After restoring the older version of Visual Build, the Oracle action ran fine.

I turned on verbose information in the output and I could see that my Oracle script had run and produced a result in the output window. Unfortunately, Visual Build was stuck on the step for many minutes. The query I was running is very quick.

Here are details from the working version:
Visual Build Professional 9.7 (x64)
Copyright 1999-2018 Kinook Software, Inc.
Windows Version: Windows Server 2012 R2 Standard
Install path: C:\Program Files\VisBuildPro9
HideConsole.exe version 1.0.0.0
SftPrintPreview_x64_U_20.dll version 2.04
VisBuildCmd.exe version 9.7.0.1
VisBuildPro.exe version 9.7.0.1
VisBuildAct.dll version 9.7.0.1
VisBuildCore.dll version 9.7.0.1
VisBuildDotNET.dll version 9.7.0.0
VisBuildExt.dll version 9.7.0.1
VisBuildInf.exe version 9.7.0.1
VisBuildMisc.dll version 9.7.0.1
VisBuildMS.dll version 9.7.0.1
VisBuildMS2.dll version 9.7.0.0
VisBuildNet.dll version 9.7.0.1
VisBuildSvr.dll version 9.7.0.1
VisBuildVCS.dll version 9.7.0.1

Here are details from the broken version:
Visual Build Professional 9.7 (x64)
Copyright 1999-2018 Kinook Software, Inc.
Windows Version: Windows Server 2012 R2 Standard
Install path: C:\Program Files\VisBuildPro9
HideConsole.exe version 1.0.0.0
SftPrintPreview_x64_U_20.dll version 2.04
VisBuildCmd.exe version 9.7.0.3
VisBuildPro.exe version 9.7.0.4
VisBuildAct.dll version 9.7.0.4
VisBuildCore.dll version 9.7.0.3
VisBuildDotNET.dll version 9.7.0.0
VisBuildExt.dll version 9.7.0.3
VisBuildInf.exe version 9.7.0.3
VisBuildMisc.dll version 9.7.0.3
VisBuildMS.dll version 9.7.0.3
VisBuildMS2.dll version 9.7.0.1
VisBuildNet.dll version 9.7.0.3
VisBuildSvr.dll version 9.7.0.4
VisBuildVCS.dll version 9.7.0.3

This is unusual. I've not had new releases of Visual Build break things. Normally, I just upgrade and everything continues to work.

kinook 01-10-2019 11:57 PM

Fixed in the latest download (VisBuildAct.dll 9.7.0.5 in Help | About after installing).

mevans 01-11-2019 03:36 PM

The fixed worked. Thanks.


All times are GMT -5. The time now is 09:11 PM.


Copyright 1999-2019 Kinook Software, Inc.