Kinook Software Forums

Kinook Software Forums (
-   [VBP] General Discussion (
-   -   "Delete Folder" doesn't work sometimes (

ambalboa 07-09-2007 03:51 PM

"Delete Folder" doesn't work sometimes
This is weird but sometimes the 'Delete Folder' action step doesn't work, giving me the following error message:

7/9/2007 2:39:50 PM: Building project step 'Delete Folder'...
7/9/2007 2:39:50 PM: Building project step 'Delete Source Code folder'...
Deleting folder 'C:\Release\1.2.3 Release\Source Code'...
The directory is not empty.

Process completed with exit code 145
7/9/2007 2:39:50 PM: Step 'Delete Source Code folder' failed

Now, the option "Delete subfolders" is checked, so even if the folder specified in the path wasn't empty, it should still delete it and everything in it, right? This happens every now and then. I ran the step a second time and it worked. Why did this happen?

kinook 07-09-2007 05:37 PM

It the Windows RMDIR command is unable to delete one or more files or folders in the specified folder (for instance, if file(s) or folder(s) are locked for use by another application), that error could occur.

All times are GMT -5. The time now is 08:18 AM.

Copyright 1999-2022 Kinook Software, Inc.