Kinook Software Forums

Kinook Software Forums (
-   [UR] General Discussion (
-   -   Error when inserting child item via tear-off toolbar (

karelt 02-09-2019 09:25 AM

Error when inserting child item via tear-off toolbar
haven't seen a better place to report a bug. If there is, kindly correct me.

Toolbar/Tree/Insert Child
Toolbar/Tree/Insert Sibling

when their menus are teared off and docked, sometimes, the buttons don't add the appropriate child/sibling. Instead they set on adding only one item type no matter what button is pressed (the type choice changes).
The wrong item inserted really has the wrong type. It's not just a wrong icon. Also the Item type does not correct itself upon restart.
When I insert the appropriate child/sibling using either RMB menu over item in the tree or using the Toolbar/Tree/Insert Child or Toolbar/Tree/Insert Sibling, the error disappears.
When Sibling toolbar worked, Child did not, closed child toolbar, created new child toolbar. The new child toolbar works, but now the sibling toolbar produces the bug.
Undocking the toolbar does not change the status of which toolbar produces a bug.

suspected source of the bug:
it seems to me that the simultaneous existence of both child and sibling toolbars
or the simultaneous existence of their buttons (when buttons from both toolbar are transferred to another toolbar)
is what starts the bug.

UR restart
insert sibling folder via toolbar button inserts folder
insert sibling text via toolbar button inserts text ... it works
insert child folder via toolbar button inserts folder
insert child text via toolbar button inserts folder ... bug
insert child text via tree/item RMB menu OR Toolbar/Tree/Insert Child/insert text insert texts
insert child text via toolbar button inserts folder ... works

Any idea?

karelt 02-10-2019 05:18 PM

Just created a folder (e.g. "X") and moved all items such as Appointments, Recycle Bin, etc there so they are out of my way. Moved this folder to be at the bottom of the item tree. Then changed its icon. Then moved to the folders with text notes above. Selected one item and tried to insert a text child item using a button from the Tree/Insert child menu, that I dragged to my custom toolbar.
This created a symbolic link of the folder X at the bottom of the item tree.
Undo worked.
Tried again. Same result.
After typing this text, went there to try it again and the error stopped repeating itself and the toolbar buttons appear to work correctly.


kinook 02-10-2019 06:14 PM

I was able to reproduce the error when clicking an item on the tear-off Insert Child toolbar, will investigate.

kinook 02-20-2019 10:35 AM

Fixed in v5.4.

karelt 02-23-2019 04:52 AM

Wow, that was fast!
Thank you very much!
It seems to work splendidly in 5.4


All times are GMT -5. The time now is 05:48 AM.

Copyright 1999-2021 Kinook Software, Inc.