Kinook Software Forums

Kinook Software Forums (http://www.kinook.com/Forum/index.php)
-   [VBP] Third Party Tools (http://www.kinook.com/Forum/forumdisplay.php?f=3)
-   -   unable to auto-locate team foundation exe (http://www.kinook.com/Forum/showthread.php?t=4074)

wallywojo 07-08-2009 05:05 PM

unable to auto-locate team foundation exe
 
Any help with this as I am building a new build machine and this is the first time I have encountered this and I do not want to explicitly supply the path as I have never had to do this for any of the other machines we use.

at this point I do have the folder where tf.exe resides in the path, so that does not seem to make a difference.

Thanks

kinook 07-08-2009 05:27 PM

The Team Foundation action auto-locates tf.exe by looking for the path to the highest installed version of Visual Studio by looking for an InstallDir value under HKLM\SOFTWARE\Microsoft\VisualStudio\.0 (for various versions) in the registry and appending \Common7\IDE\tf.exe to it if found.

If tf.exe's path is in VBP's PATH environment, you can specify tf in the Override field on the Options tab of the Team Foundation action.

wallywojo 07-08-2009 10:07 PM

I found the registry values to be the same on both machines and if I fixed up the string value it did not work. Have any other ideas on the auto-detect?

kinook 07-09-2009 12:19 AM

Please ZIP and send to support@kinook.com:
1) The info from Help | About | Install Info
2) A screen shot of System properties (Windows+Break)
3) The .bld file
4) A build log file
5) An export of the registry key HKLM\SOFTWARE\Microsoft\VisualStudio

Thanks.

wallywojo 07-09-2009 10:30 AM

thanks, this was due to an old version of visual build. Once I updated to 6.7a it was able to find tf.exe.


All times are GMT -5. The time now is 11:14 PM.


Copyright 1999-2019 Kinook Software, Inc.