Kinook Software Forums

Kinook Software Forums (
-   [VBP] Third Party Tools (
-   -   Failed to create process: Access is denied error (

DavidClarke 07-08-2014 01:56 PM

Failed to create process: Access is denied error
I'm using
Windows 8.1
Visual Build Pro 7.7a
Visual Studio 2010 SP1
Visual Studio 2012 Update 4

I created a brand new VS2012 C# forms project and do not any any controls or code; I compile it with no errors. Then I create a new build script (VBP) and use the “Make VS.NET” task to build the solution. I do not select any extra options on the build step. Run the build script and I get the error:
Failed to create process: Access is denied.

I have set VS2010/VS2012/VBP all to run as administrator and additionally VBP is set to Windows 7 compatibility. I am admin on my PC and I also have completely disabled the UAC (in registry too) and granted users full rights to the VS application folders.

After enabling diagnostic logging (VBP) I see this:
Command: "\"c:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\" "C:\Storage\Test Programs\TestingBuildScript\Testing\Testing.sln" /build "Debug|Any CPU"

Notice how there is an extra "." character in "". If I run this command on a command line it works IF I remove the extra "." character. I also noted that VBP tries to build using VS2010 version of "". This may be normal but not sure.
If I create a new project using VS2010 everything works fine in studio and VBP. In this case the command logged shows a single “.” character as it should.

This error seems to happen with all VS2012 projects. This is a new PC so VS2010/VS2012/VBP were all freshly installed.

If I add my credentials to the "Advanced" tab on the step I get this error:
Failed to create process: The stub received bad data.

I have a strong feeling the command is being formatted incorrectly (with the extra "." character) but I cannot find where this is done. Any suggestions???

kinook 07-08-2014 06:27 PM

kinook 07-09-2014 08:46 AM

Visual Build v7 does not support VS 2012 or VS 2013. v8.1 was the first version to support VS 2012, and v8.5 was the first version to support VS 2013.

DavidClarke 07-09-2014 08:55 AM

I understand Kinook does not support older releases of VBP so I posted here in the hopes others might be running with a similar environment and have some ideas.

It seems to me it is probably something simple as the command is getting formatted incorrectly. If the commands are formatted from the registry, I cannot find where.

kinook 07-09-2014 09:02 AM

You might try overriding the location on the Options tab.

DavidClarke 07-09-2014 09:06 AM

I have tried overriding the location to the 2010/2012 versions and it works. The problem is the sample script I sent was part of a far larger script that sets up a development environment. I won't be able to modify our "normal" build script. The small script I created because I could duplicate the issue and try to solve it without running the larger script.

How is the command for DEVENV.COM created? I tried searching the registry but I could not find it.

kinook 07-09-2014 09:19 AM

There is logic in the Make VS action to construct the command-line call. Apparently that logic in Visual Build v7 doesn't work with VS 2012, or perhaps there is a problem due to running in compatibility mode. Most likely, the only ways to resolve are to override the path or upgrade Visual Build.

DavidClarke 07-09-2014 09:28 AM

The eval version of VBP (v8.7) worked.

I do appreciate the suggestions.

All times are GMT -5. The time now is 02:06 PM.

Copyright 1999-2022 Kinook Software, Inc.