View Single Post
Old 05-02-2019, 11:18 AM
dhollman dhollman is online now
Registered User
Join Date: 09-26-2013
Posts: 9
SignTool Error: SignerSign() failed when run from VBP

I have recently started using a code signing certificate which is housed on a USB dongle.

Previously when using a PFX file for the certificate I could sign code without issue from VBP. But now I am running into an error:

Done Adding Additional Store
Error information: "Error: SignerSign() failed." (-2147023673/0x800704c7)
SignTool Error: An unexpected internal error has occurred.

This occurs both when using the Sign Code action, or even just running signtool in a Run Program action. (Same error, either way).

If I run signtool manually on the command line (not using VBP) there is no error.

What has to happen when signtool runs is that some local software interfaces with the USB dongle and prompts you for a password before signing can take place. This works from the command line but does NOT occur when running from VBP. This is likely the cause of the mysterious error above.

I'm not sure what to do to get this to work from VBP...

Reply With Quote