View Single Post
Old 04-08-2021, 11:10 AM
Spliff Spliff is online now
Registered User
Join Date: 04-07-2021
Posts: 72
Flag problems with custom font

There are 7 flags (flag formats/codes, and an 8th command to delete any flag code, i.e. to reset the flag column of the database to NULL) where it is possible to change the text and/or background color, without having to change the (default) font; this works as expected.

In order to get the font attributes bold, italics and underlined though, you must use a "custom font" first, for which you can use the default font, with default size, etc. (which I do), or some other.

Assigning, or changing the assignment, with such "custom font" flags, presents a problem though, since often, the correct formatting of the "custom font" will not be displayed, or it will be displayed just for some seconds after leaving the item, after assignment of the flag, then it reverts to default (non-formatted) in the tree, whilst retaining the correct flag attribute though in the attributes pane, and even a "Compact and repair" will not show the correct formatting in the tree, just closing and reopening the database will do.

Sometimes, in order to retain/show the correct formatting (bolding or italicizing in my case) in the tree (the internal flag code is always retained, the problem is just in the tree), it helps to quickly delete the flag just after assigning it, then to reassign it again, but that often works and often doesn't.

The phenomenon of "custom font" not being correctly formatted in the tree, occurs independently of the way of assigning the flag, be it by (assigned) shortcut or by selecting the flag in the Item Attributes panes and then pressing Enter; it occurs independently of your also renaming the flag or to leave the original name (see below).

The phenomenon occured with several original flags I had reassigned to other formats, but I have not tried every possible combination; in order to better identify the problem, I have reassigned the "Yellow" flag in the following way, tried several times, also with just one database open, and without the problem disappearing:

Yellow flag, not renamed, is called Yellow, not "Hide", text black, background default (i.e. white), custom font Verdana Bold 12 point (which had to be specified here to get the "bold" but which corresponds, without the "bold", to my default tree format). No "hide", no "custom icon". I do not show the flags themselves, just use them as a means to format the item title in the tree, but I also tried with displaying the flags, and the problem didn't go away.

I could try specific settings to better identify what causes the problem.
Reply With Quote