View Single Post
  #1  
Old 02-09-2019, 09:25 AM
karelt karelt is online now
Registered User
 
Join Date: 05-23-2016
Posts: 43
Exclamation Error when inserting child item via tear-off toolbar

Hi,
haven't seen a better place to report a bug. If there is, kindly correct me.

concerning:
Toolbar/Tree/Insert Child
Toolbar/Tree/Insert Sibling

bug:
when their menus are teared off and docked, sometimes, the buttons don't add the appropriate child/sibling. Instead they set on adding only one item type no matter what button is pressed (the type choice changes).
The wrong item inserted really has the wrong type. It's not just a wrong icon. Also the Item type does not correct itself upon restart.
When I insert the appropriate child/sibling using either RMB menu over item in the tree or using the Toolbar/Tree/Insert Child or Toolbar/Tree/Insert Sibling, the error disappears.
When Sibling toolbar worked, Child did not, closed child toolbar, created new child toolbar. The new child toolbar works, but now the sibling toolbar produces the bug.
Undocking the toolbar does not change the status of which toolbar produces a bug.

suspected source of the bug:
it seems to me that the simultaneous existence of both child and sibling toolbars
or the simultaneous existence of their buttons (when buttons from both toolbar are transferred to another toolbar)
is what starts the bug.


example:
UR restart
insert sibling folder via toolbar button inserts folder
insert sibling text via toolbar button inserts text ... it works
insert child folder via toolbar button inserts folder
insert child text via toolbar button inserts folder ... bug
insert child text via tree/item RMB menu OR Toolbar/Tree/Insert Child/insert text insert texts
insert child text via toolbar button inserts folder ... works

Any idea?
Best,
K

Last edited by karelt; 02-09-2019 at 09:52 AM.
Reply With Quote