Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 12-16-2009, 12:44 PM
bgallant bgallant is online now
Registered User
 
Join Date: 12-16-2009
Posts: 3
Zombie VisBuildPro.exe hanging around after build

We are using Visual Build Pro 7.2. We are using the scheduled task to launch VisBuildPro.exe. Most of the time the build succeeds and it completes all the steps but we are left with a VisbuilPro.exe running in the task manager and of course the scheduled tasks shows that it is still running. We are creating a marker file that prevents another build from running if the marker files exist. We got that from the Visual Build samples. The marker file is deleted at the end of the build as it should. We have the scheduled task run and start a build every 10 minutes if the marker file does not exist. I just put an Exit action as the last step hoping to kill the rogue Visbuildpro.exe that hangs around. If the rogue task is sitting there running and a checkin is submitted nothing gets built unless we manually kill the rogue task or it goes away by itself after a couple of hours. Can anyone help? Would it help to use the VisBuildCmd.exe?

Thank you.
Reply With Quote
  #2  
Old 12-16-2009, 01:24 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,742
Trying VisBuildCmd.exe couldn't hurt. If updating to 7.2a doesn't help, you could add a Kill Process step at the end of the build to kill [Builder.ProcessID].
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 12:17 PM.


Copyright 1999-2019 Kinook Software, Inc.