Kinook Software Forums

Go Back   Kinook Software Forums > Ultra Recall > [UR] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 11-14-2008, 04:58 AM
Roaster Roaster is online now
Registered User
 
Join Date: 08-01-2007
Posts: 51
Outlook mails and embedded images

Hi,

Using UR 3.5b (Pro) I now tried to store an Outlook mail with embedded images into my UR database: The text is copied correctly, but the images are missing.

When copying this message content, using CTRL+C and pasting it into a new UR item, those images are too missing!
However I noticed one slight difference here: the place where those images should be displayed is surrounded by a a rectangle when clicking into those empty lines.
This indicates that UR is aware that there should be some images but cannot show them/or did not take them over.

OTH I've now copied this message text and its images into Winword and it too does not show them. Is there a known issue with copying and pasting with Outlook?

Thanks for any answers!
Reply With Quote
  #2  
Old 11-14-2008, 01:36 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,758
Please save the Outlook message in .msg format and ZIP and send it to support@kinook.com. Thanks.
Reply With Quote
  #3  
Old 11-14-2008, 09:42 PM
armsys armsys is online now
Registered User
 
Join Date: 12-19-2007
Posts: 647
Roaster,
Your issue can be reproduced here, namely, an image embedded in an Outlook message (mail) can't be copied to a UR text Info Item. It's an issue of Outlook, not UR.
Here's my workaround solution:
1. Press Ctrl+R;
2. Press Ctrl+C to copy the message;
3. In your UR Info Item, press Ctrl+V.
And now you get your picture now.

I don't know why it works, but that's how it works after hours of experiment.

Armstrong
Reply With Quote
  #4  
Old 11-15-2008, 12:32 AM
armsys armsys is online now
Registered User
 
Join Date: 12-19-2007
Posts: 647
Hi Roaster,
Are you running IE7?
Armstrong
Reply With Quote
  #5  
Old 11-17-2008, 03:00 AM
Roaster Roaster is online now
Registered User
 
Join Date: 08-01-2007
Posts: 51
Armstrong,

yes, I am running IE7 (without any updates) on Windows XP Pro, Outlook 2003 (SP3).

Unfortunately your given solution does not work here either. Thanks anyway for your hints.

I've now sent the mail in question to Kinook support.
Reply With Quote
  #6  
Old 11-17-2008, 03:09 AM
armsys armsys is online now
Registered User
 
Join Date: 12-19-2007
Posts: 647
Roaster,
Actually, your issue is a known one amongst the IE7 users with exactly the similar configuration as yours. The only solution is to remove IE7. Definitely, it's not a UR issue.
I tested again the proposed solution and it works fine.
When copying directly with Ctrl+C, somehow it removes all HTML codes including the image(s).
However, if you pretend to reply the email with Ctrl+R, copying the content with Ctrl+C will copy the whole HTML codes, including the images.

Armstrong
Reply With Quote
  #7  
Old 11-17-2008, 05:32 AM
Roaster Roaster is online now
Registered User
 
Join Date: 08-01-2007
Posts: 51
Thanks again for replying. Unfortunately this work around does not work either as already mentioned before.

The message is in HTML format, I select all content by pressing Ctrl+A followed by Ctrl+C and copy it into a newly create UR item.
The images are still missing though some space was reserved for them-

I'm mainly using Firefox 3.x, but I guess UR is using some DLLs from IE/Outlook which causes this issue.
Reply With Quote
  #8  
Old 11-17-2008, 05:41 AM
armsys armsys is online now
Registered User
 
Join Date: 12-19-2007
Posts: 647
Hi Roaster,
The Outlook embedded image noncopying is a universal issue for all IE7 users. Please try to copy the email message (Ctrl+A, Ctrl+C) to Microsoft Word 2003. You'll see the image(s) will be missing too. This alone should prove it's not an issue of UR. As mentioned previously, you must uninstall IE7 entirely. In my case, I can't because some mission critical apps such as MindManager require IE7.

Armstrong
Reply With Quote
  #9  
Old 11-17-2008, 06:00 AM
armsys armsys is online now
Registered User
 
Join Date: 12-19-2007
Posts: 647
Hi Roaster,
Another solution.
1. Press Win+R, type msMspaint, and press Enter.
2. Go back to your Outlook email message in question.
Right-Click the image and copy (the first option in the context menu) it.
3. Go back to Paint, press Ctrl+V.
4. Copy that image from Paint to the UR Info Item (text).

Armstrong
Reply With Quote
  #10  
Old 11-17-2008, 06:27 AM
Roaster Roaster is online now
Registered User
 
Join Date: 08-01-2007
Posts: 51
Armstrong,

to be clear, I did not accuse UR in any way, to be the cause of this issue. As a programmer, I know that there are lots of possible problems which could make your application crash or not working properly.

I've posted this problem here at least to get a confirmation from others which have this issue, too, or perhaps to get a work around like you already thankfully posted here.

Of course I could copy the image by hand however this message, where I've got the problems with, has got some more and I really like the fire-and-forget function of UR to not copy things manually but using the various application plugins.

As initially written, I already tried to copy the message content into WinWord without any success either, no images appeared.
So I already guessed that the cause of this problem could be somewhere outside of UR - I just tried to get some hints here to get messages with images properly copied into UR again.

cu
Reply With Quote
  #11  
Old 11-17-2008, 06:44 AM
armsys armsys is online now
Registered User
 
Join Date: 12-19-2007
Posts: 647
Hi CU,

Thanks for your reply.
In fact, what you're raising is a major issue. Try:
http://www.google.com.hk/search?q=ou...ient=firefox-a
I've been struggling with the issue for a long while still without a perfect solution.
For UR, I do a manual copy. It's tedious but it works.

Armstrong
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 05:35 PM.


Copyright 1999-2019 Kinook Software, Inc.