Kinook Software Forums

Go Back   Kinook Software Forums > Ultra Recall > [UR] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 01-29-2005, 08:46 PM
Steve10 Steve10 is online now
Registered User
 
Join Date: 01-29-2005
Posts: 15
Unhappy Error Loading Item Detail View

I have a rather small database using the 1.1 demo and have added several PDF files and Pictures to various Info Item Pages.

I went to select one of the previously saved pages that had a few pictures in it and receive 2 error messages. This page had been working fine for the past 2 days so I know it saved the data originally. I have had no computer crashes or any other system problems.

The first error says "Error Loading Item Detail View - Error Decompressing Binary Data" and the second error is an "Access Violation Error" which I have attached.

After I click through both errors the page opens blank.

I have Compacted and Repaired the Database and even rebooted my computer and I still cannot get the page to open.

Every other page in the database opens fine except this one.
Attached Images
 
Reply With Quote
  #2  
Old 01-31-2005, 09:26 AM
kevina kevina is online now
Registered User
 
Join Date: 03-27-2003
Posts: 825
It sounds like the error you are seeing is related to the automatic compression that occurs of the data stored with an Info Item (such as the document when storing contents or the rich text of Text or other templates).

We haven't seen (or heard of) this error occurring before. Can you reproduce Info Items that behave this way? Do you remember the steps that were taken to create the Info Item in question?

Can you zip and email the Info Database with the problem to support@kinook.com for our analysis?

If you can't reproduce the problem and just want to continue using the Info Database, you should be able to permanently delete the Info Item and recreate it (which should eliminate the problem). Ctrl+Shift+Del will permanently delete the selected Info Item(s).
Reply With Quote
  #3  
Old 01-31-2005, 12:20 PM
Steve10 Steve10 is online now
Registered User
 
Join Date: 01-29-2005
Posts: 15
I have sent a backup of the file with the error in it. I removed all my other pages except the one that gives the error to keep the file size small.

I am not sure exactly how to reproduce it but I can tell you I copied several pictures into a Text Info page from a web site.

I have since deleted that page and have moved on without any other errors in that data file but I lost all the info in that page.

What I was trying to do was copy some pictures from a web page to store along with related pages and text.

For example I went to this web site: http://www.sonos.com/products/controller/images.htm and right clicked on a picture, selected Copy and then back in UR I Pasted the picture into a Text page. I did this with about 3-4 pictures along with some text under each picture and everything was great.

I have several other Text pages in my file that I have done this with and they are all fine. I had even viewed this page several times after I was finished pasting the pictures and everything was fine. Then all of a sudden I got this error but only on the one Text page. All my other pages where I had also copied pictures were fine.
Reply With Quote
  #4  
Old 02-01-2005, 01:06 PM
kevina kevina is online now
Registered User
 
Join Date: 03-27-2003
Posts: 825
Thanks to a customer supplied Info Database demonstrating this error, we have identified a bug that could cause data corruption under rare circumstances when compressing data stored with an Info Item (that isn't detectable until the data is uncompressed).

Note that if you see this error, you will need to delete the offending Info Item and recreate it, even after applying this bug fix. The fix should prevent data from being corrupted again.

Ultra Recall version 1.2 is now available and fixes this bug as reported.

Note: it is highly recommended that you make a backup of your Info Databases before upgrading to a new version.
Reply With Quote
  #5  
Old 02-01-2005, 08:37 PM
Steve10 Steve10 is online now
Registered User
 
Join Date: 01-29-2005
Posts: 15
Thumbs up

Thanks for the fast turn around time. It's great to see fast responses to bugs and suggestions. Keep up the good work. You have a great product and we all want to make it even better.
Reply With Quote
  #6  
Old 02-01-2005, 10:05 PM
ExtraLean ExtraLean is online now
Registered User
 
Join Date: 01-19-2005
Posts: 46
Quote:
Originally posted by Steve10
Thanks for the fast turn around time. It's great to see fast responses to bugs and suggestions. Keep up the good work. You have a great product and we all want to make it even better.
Ditto... on both accounts!
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 09:51 AM.


Copyright 1999-2019 Kinook Software, Inc.