Kinook Software Forum

Go Back   Kinook Software Forum > Visual Build Professional > [VBP] Third Party Tools

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 10-18-2023, 04:45 AM
martijntonies martijntonies is online now
Registered User
 
Join Date: 05-11-2011
Posts: 8
Code signing with USB token: no dialog in Windows 7

Hi,

I'm using a code signing method with signtool and YubiKey.

On Windows 10 (VMWare), this step executes, shows the pin code dialog and signs the file when the pin is entered.

On Windows 7 (VMWAre), this step executes, but does not show the dialog and then just hangs, counting the seconds the task is taking.

When I use signtool manually on Windows 7, the pin code dialog is being displayed without problems.

Any idea what to do? Currently using Visual Build Pro, 10.9


With regards,

Martijn Tonies
Reply With Quote
  #2  
Old 10-18-2023, 04:18 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,975
1) Check the 'Log the command-line that is used' on the Advanced tab of the Sign Code action
2) Rebuild the step
3) Copy the signcode command-line from the build output into a new Run Program action
4) Uncheck 'Hide application window' on the Program tab
5) Build the Run Program step
Reply With Quote
  #3  
Old 10-19-2023, 03:08 AM
martijntonies martijntonies is online now
Registered User
 
Join Date: 05-11-2011
Posts: 8
I'll give it a try.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 08:09 AM.


Copyright 1999-2023 Kinook Software, Inc.