Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] Third Party Tools

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 05-04-2020, 12:57 PM
mevans mevans is online now
Registered User
 
Join Date: 04-21-2015
Posts: 31
PowerShell 6 and 7 support

I've only used PowerShell 5.1 and below with Visual Build. The recent release of PowerShell 7 is supposed to have more backward compatibility with PowerShell 5.1 and below, so I'm considering trying it out.

Does Visual Build support running PowerShell 6 or 7 scripts? If so, what is the recommended approach? I guess if nothing else, I could try overriding the executable in the options tab, but I want to see if you have a recommendation.
Reply With Quote
  #2  
Old 05-04-2020, 10:47 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,752
It does now, in the latest download (VisBuildCore.dll 10.2.0.1). For the v7.1 preview, you will need to specify the path to pwsh.exe in the Override field on the Options tab.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 01:44 AM.


Copyright 1999-2019 Kinook Software, Inc.