Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #31  
Old 03-25-2010, 06:50 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,706
What is the result with the attached test2.bld?

Also, please send/post your current C:\Documents and Settings\All Users\Application Data\Kinook Software\Visual Build Professional 7\VisBuildPro.config file.

And what is the result with v7.1 (uninstall, then download+install http://www.kinook.com/Download/Old/VisBuildPro71.exe).

Thanks.
Attached Files
File Type: bld test2.bld (611 Bytes, 568 views)
Reply With Quote
  #32  
Old 03-25-2010, 04:26 PM
citect citect is online now
Registered User
 
Join Date: 11-13-2008
Posts: 30
Do you want me to try test.bld and not test2.bld on 7.1?

The result of test2.bld is as follow when using 7.5:

C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test>"c:\Program Files\VisBuildPro7\VisBuildCmd.exe" test2.bld

VisBuildCmd, Version 7.5.0.3
Copyright (C) 1999-2010 Kinook Software, Inc. All rights reserved.
Registered to: Citect by Schneider Electric (5-computer license)

26/03/2010 8:21:52 AM: Starting Build: 'C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test\test2.bld'
26/03/2010 8:21:52 AM: Building project step 'Project steps'...
26/03/2010 8:21:52 AM: Building project step 'Run Program'...
Step default property 'command' = 'C:\WINDOWS\system32\cmd.exe /C echo 26/03/2010 8:21:52 AM abc'
26/03/2010 8:21:52 AM abc
26/03/2010 8:21:52 AM: Building project step 'Show exit code'...
Exit code = 0

Output = Step default property 'command' = 'C:\WINDOWS\system32\cmd.exe /C echo 26/03/2010 8:21:52 AM abc'
26/03/2010 8:21:52 AM abc
26/03/2010 8:21:52 AM: Build successfully completed (elapsed = 00:00:00).

C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test>
Attached Files
File Type: txt visbuildpro.config.txt (1.8 KB, 412 views)
Reply With Quote
  #33  
Old 03-25-2010, 04:46 PM
citect citect is online now
Registered User
 
Join Date: 11-13-2008
Posts: 30
I ve got the following result when 7.1 is installed, Test.bld is still not working:


TEST.BLD result:

C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test>"c:\Program Files\VisBuildPro7\VisBuildCmd.exe" test.bld

VisBuildCmd, Version 7.1.0.1
Copyright (C) 1999-2009 Kinook Software, Inc. All rights reserved.
Evaluation Version: 30 days remaining

26/03/2010 8:44:15 AM: --------------------Starting Build: 'C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test\test.bld'--------------------
26/03/2010 8:44:15 AM: Building project step 'Project steps'...
26/03/2010 8:44:15 AM: Building project step 'Create batch file'...
Step default property 'Filename' = 'C:\DOCUME~1\GILLES~1.FAU\LOCALS~1\Temp\test.bat'
Creating file C:\DOCUME~1\GILLES~1.FAU\LOCALS~1\Temp\test.bat
26/03/2010 8:44:15 AM: Building project step 'Run Program'...
Step default property 'command' = 'C:\DOCUME~1\GILLES~1.FAU\LOCALS~1\Temp\test.bat abc'
26/03/2010 8:44:15 AM: Building project step 'Show exit code'...
0
26/03/2010 8:44:15 AM: Build successfully completed.

C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test>






TEST2.BLD result:

C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test>"c:\Program Files\VisBuildPro7\VisBuildCmd.exe" test2.bld

VisBuildCmd, Version 7.1.0.1
Copyright (C) 1999-2009 Kinook Software, Inc. All rights reserved.
Evaluation Version: 30 days remaining

26/03/2010 8:48:26 AM: --------------------Starting Build: 'C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test\test2.bld'------------------
26/03/2010 8:48:26 AM: Building project step 'Project steps'...
26/03/2010 8:48:26 AM: Building project step 'Run Program'...
Step default property 'command' = 'C:\WINDOWS\system32\cmd.exe /C echo 26/03/2010 8:48:26 AM abc'
26/03/2010 8:48:26 AM abc
26/03/2010 8:48:26 AM: Building project step 'Show exit code'...
Exit code = 0

Output = Step default property 'command' = 'C:\WINDOWS\system32\cmd.exe /C echo 26/03/2010 8:48:26 AM abc'
26/03/2010 8:48:26 AM abc
26/03/2010 8:48:26 AM: Build successfully completed.

C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test>
Reply With Quote
  #34  
Old 03-25-2010, 05:33 PM
citect citect is online now
Registered User
 
Join Date: 11-13-2008
Posts: 30
I might have some useful info:


After re-installing 7.1 and 7.2a the TEST.bld would still not work. But I was using the same cmd window as 7.5 to run the VisBuildCmd.

After opening a new cmd window and run VisBuildCmd on 7.1 then test.bld works fine.

Then I re-installed 7.5 and run VisBuildCmd on the same cmd window, TEST.bld is not working. Actually the bat file is not working anymore if I run it directly on the cmd window. It looks like the output are disabled for this cmd window but not entirely sure because I pretty sure that batch file is not executed at all.

Open a new cmd windows and run the same batch file directly from the window then the batch file works fine.


See the results:

*** Batch file run directly on a new cmd window (Works fine):

C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test>tfsindex.bat

C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test>echo
ECHO is on.

C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test>echo
ECHO is on.

C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test>echo
ECHO is on.

C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test>rem D:\DrvGrp\NonODC\Utilities\DriverPackBuilder\tfsin dex.cmd



*** test.bld using 7.1 on the same cmd window (works fine):

C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test>"c:\Program Files\VisBuildPro7\VisBuildCmd.exe" test.bld

VisBuildCmd, Version 7.1.0.1
Copyright (C) 1999-2009 Kinook Software, Inc. All rights reserved.
Evaluation Version: 30 days remaining

26/03/2010 9:05:38 AM: --------------------Starting Build: 'C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test\test.bld'--------------------
26/03/2010 9:05:38 AM: Building project step 'Project steps'...
26/03/2010 9:05:38 AM: Building project step 'Create batch file'...
Step default property 'Filename' = 'C:\DOCUME~1\GILLES~1.FAU\LOCALS~1\Temp\test.bat'
Creating file C:\DOCUME~1\GILLES~1.FAU\LOCALS~1\Temp\test.bat
26/03/2010 9:05:38 AM: Building project step 'Run Program'...
Step default property 'command' = 'C:\DOCUME~1\GILLES~1.FAU\LOCALS~1\Temp\test.bat abc'

C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test>echo 26/03/2010 9:05:38 AM abc
26/03/2010 9:05:38 AM abc
26/03/2010 9:05:39 AM: Building project step 'Show exit code'...
0
26/03/2010 9:05:39 AM: Build successfully completed.




*** test.bld using 7.5 on the same cmd window (Does not work):

C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test>"c:\Program Files\VisBuildPro7\VisBuildCmd.exe" test.bld

VisBuildCmd, Version 7.5.0.3
Copyright (C) 1999-2010 Kinook Software, Inc. All rights reserved.
Trial version: 30 days remaining

26/03/2010 9:12:35 AM: Starting Build: 'C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test\test.bld'
26/03/2010 9:12:35 AM: Building project step 'Project steps'...
26/03/2010 9:12:35 AM: Building project step 'Create batch file'...
Step default property 'Filename' = 'C:\DOCUME~1\GILLES~1.FAU\LOCALS~1\Temp\test.bat'
Creating file C:\DOCUME~1\GILLES~1.FAU\LOCALS~1\Temp\test.bat
26/03/2010 9:12:35 AM: Building project step 'Run Program'...
Step default property 'command' = 'C:\DOCUME~1\GILLES~1.FAU\LOCALS~1\Temp\test.bat abc'
26/03/2010 9:12:35 AM: Building project step 'Show exit code'...
0
26/03/2010 9:12:36 AM: Build successfully completed (elapsed = 00:00:01).

C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test>



*** Batch file run directly on the same cmd window (Does not work):

C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test>tfsindex.bat

C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test>
Reply With Quote
  #35  
Old 03-25-2010, 05:42 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,706
Please build the attached init.bld project in the GUI and exit Visual Build, then in a new Command Prompt, build test3.bld (and also post VisBuildPro.config again). Thanks.
Attached Files
File Type: zip forum.zip (868 Bytes, 417 views)
Reply With Quote
  #36  
Old 03-25-2010, 05:57 PM
citect citect is online now
Registered User
 
Join Date: 11-13-2008
Posts: 30
To run init.bld project I had to install 7.5.0.4 (This version is not available for download, is it?)


Run the test.bld on a new cmd window and it works file, see result below:

C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test>"c:\Program Files\VisBuildPro7\VisBuildCmd.exe" test.bld

VisBuildCmd, Version 7.5.0.4
Copyright (C) 1999-2010 Kinook Software, Inc. All rights reserved.
Trial version: 30 days remaining

26/03/2010 9:52:47 AM: Starting Build: 'C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test\test.bld'
26/03/2010 9:52:47 AM: Building project step 'Project steps'...
26/03/2010 9:52:47 AM: Building project step 'Create batch file'...
Step default property 'Filename' = 'C:\DOCUME~1\GILLES~1.FAU\LOCALS~1\Temp\test.bat'
Creating file C:\DOCUME~1\GILLES~1.FAU\LOCALS~1\Temp\test.bat
26/03/2010 9:52:47 AM: Building project step 'Run Program'...
Step default property 'command' = 'C:\DOCUME~1\GILLES~1.FAU\LOCALS~1\Temp\test.bat abc'

C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test>echo 26/03/2010 9:52:47 AM abc
26/03/2010 9:52:47 AM abc
26/03/2010 9:52:47 AM: Building project step 'Show exit code'...
0
26/03/2010 9:52:47 AM: Build successfully completed (elapsed = 00:00:00).

C:\Documents and Settings\gilles.faure\My Documents\temp\kinook test>
Attached Files
File Type: txt visbuildpro.config.txt (1.8 KB, 399 views)
Reply With Quote
  #37  
Old 03-25-2010, 07:08 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,706
Ok, it looks like the issue was with a change to improve capturing of Unicode text from console apps (apparently this only works on Windows Vista and later). Disabling that option (what init.bld does) in the 7.5.0.4 build will work. We have also backed that change out, and the main download should now work as expected (VisBuildCmd.exe 7.5.0.2 -- uninstall the current version first) from a new Command Prompt. Thanks.
Reply With Quote
  #38  
Old 03-25-2010, 07:45 PM
citect citect is online now
Registered User
 
Join Date: 11-13-2008
Posts: 30
thanks for that, it seems to work. Your effort are appreciated
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 10:16 AM.


Copyright 1999-2019 Kinook Software, Inc.