Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] Third Party Tools

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 09-25-2008, 01:21 AM
mweinberger mweinberger is online now
Registered User
 
Join Date: 12-23-2005
Posts: 40
Building an InstallShield 2009 project

Hi,

I have been using Visual Build Professional successfully building my project and compiling / building the InstallShield 2008 portion successfully. I upgraded to InstallShield 2009. I build the project manually using InstallShield 2009 and everything is fine. I then removed the previous version. I opened my VB Pro project and went to the step that builds / runs InstallShield. I went to the Script Editor and changed the objInst variable to point from “ISWiAuto14.ISWiProject” to “ISWiAuto15.ISWiProject”. I checked the registry and the new tag is there. Here is the error result that I get:

9/24/2008 9:38:30 PM: --------------------Starting Build: 'JobFish.bld'--------------------
9/24/2008 9:56:01 PM: Building project step 'Build the installation utility'...
Unable to locate InstallShield compiler executable
9/24/2008 9:56:02 PM: Step 'Build the installation utility' failed
9/24/2008 9:56:02 PM: Build ended.

Here is the top level starting step script:

function vbld_StepStarting()
Dim objInst, objUpgradeTableEntry

'Create the InstallShield Developer automation object
Set objInst = CreateObject("ISWiAuto15.ISWiProject") 'For InstallShield 2009
'use "ISWiAutomation.ISWiProject" for InstallShield Developer
'use "ISWiAutomation9.ISWiProject" for DevStudio 9
'use "ISWiAuto10.ISWiProject" for InstallShield X
'use "ISWiAuto1050.ISWiProject" for InstallShield 10.5
'use "ISWiAuto11.ISWiProject" for InstallShield 11
'use "ISWiAuto1150.ISWiProject" for InstallShield 11.5
'use "ISWiAuto12.ISWiProject" for InstallShield 12

'Open the project file
objInst.OpenProject Step.ExpProperty(Builder, "Filename")

'Other code comes here.
...

'Close the IS project and save the changes.
objInst.SaveProject
objInst.CloseProject
end function

What is the problem? I even tried rebooting my desktop to no avail.

I am using version 6.7a.

Thanks in advance
Reply With Quote
  #2  
Old 09-25-2008, 11:39 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,911
Try reinstalling or repairing InstallShield. The VBP InstallShield action is unable to locate the IS command-line executable, probably due to some missing registry entries. Alternatively, specify the full drive+path to IsCmdBld.exe in the 'Specify the InstallShield executable' field on the Options tab of the InstallShield action.
Reply With Quote
  #3  
Old 09-25-2008, 04:06 PM
mweinberger mweinberger is online now
Registered User
 
Join Date: 12-23-2005
Posts: 40
Hi,

The latter worked, namely to specify the command line. That took me a minute to find where that was (last tab), but that worked.

I am still cranky, as the auto finding of the InstallShield executable has always worked. I installed InstallShield 2009 from scratch, not overriding anything. InstallSield works. I guess it is possible, although doubtful, that Acresso has a bug in their own utility, but I highly doubt it.

I should probably open up a service request with them and have the two of you hammer out the topic. It should work automatically, as it did before, but at least now I can build my projects, which is a relief.

Thanks for getting back to me so quickly.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 11:34 AM.


Copyright © 1999-2022 Kinook Software, Inc.