Kinook Software Forums

Go Back   Kinook Software Forums > Ultra Recall > [UR] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 03-02-2014, 04:45 PM
PJMiller PJMiller is online now
Registered User
 
Join Date: 02-06-2014
Posts: 42
Scalable Vector Graphics

Is there any way of displaying an SVG file in the main editing window?

SVG is and XML variant, if I try to display it in Ultra Recall it just displays the text. If I display them in an external browser (such as Firefox) then they display OK but in a separate window.
Reply With Quote
  #2  
Old 03-02-2014, 04:52 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,752
Remove .xml from Tools | Options | Editor | File extensions to display in text editor and add it to Tools | Options | Browser | File extensions to display in browser view.
Reply With Quote
  #3  
Old 03-03-2014, 12:29 PM
PJMiller PJMiller is online now
Registered User
 
Join Date: 02-06-2014
Posts: 42
I have set the options you suggested.

UR still displays the .SVG file as text in the main edit pane.

If I display it externally then it displays correctly within Firefox.

Name:  Failiure.png
Views: 143
Size:  164.4 KB
Reply With Quote
  #4  
Old 03-03-2014, 12:41 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,752
Remove .xml (not .svg) from Tools | Options | Editor | File extensions to display in text editor and add .xml (not .svg) to Tools | Options | Browser | File extensions to display in browser view.
Reply With Quote
  #5  
Old 03-03-2014, 05:58 PM
PJMiller PJMiller is online now
Registered User
 
Join Date: 02-06-2014
Posts: 42
I must admit the previous one was with .SVG in the list of 'File extensions to display in internal browser view' because when I put .XML in there as you suggested this happens.

Name:  Fail2.png
Views: 133
Size:  144.1 KB

So far I have failed to find a combination that works. But it displays OK in an external browser so it isn't a total loss.
Reply With Quote
  #6  
Old 03-03-2014, 06:51 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,752
Which version+SP of Windows and Internet Explorer do you have? Can you post or ZIP and send the .svg file? Thanks.
Reply With Quote
  #7  
Old 03-04-2014, 06:53 AM
PJMiller PJMiller is online now
Registered User
 
Join Date: 02-06-2014
Posts: 42
It's a 64 bit windows.

OS Name Microsoft Windows 7 Home Premium
Version 6.1.7601 Service Pack 1 Build 7601

I don't know what version of Internet Exploiter I have, I used it once when I first got the computer to download Firefox. Unless it has been maintained by Windows update then it will be the one which came with the machine.

The .SVG file was generated by Graphviz which uses a subset of the full .SVG standard to generate its graphs, it is one of the examples from the manual.

SVG files generated by Inkscape behave differently (they still don't work in the internal browser but work when displayed in Firefox) they display the raw XML source code with syntax highlighting appropriate to XML, but not the picture.

I have attached a .ZIP file of the .SVG file I was using as a test. Hope this helps.

Testgraph.zip
Reply With Quote
  #8  
Old 03-04-2014, 07:19 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,752
After settings the options as mentioned, here's what I get on Win7 x64 SP1 w/ IE 11.0.9600.16518.
Attached Images
 
Reply With Quote
  #9  
Old 03-04-2014, 08:22 AM
PJMiller PJMiller is online now
Registered User
 
Join Date: 02-06-2014
Posts: 42
Finally found internet explorer, it is still on the system.

Name:  iexplore.png
Views: 120
Size:  40.2 KB

Is this used even if Firefox is installed?
Reply With Quote
  #10  
Old 03-04-2014, 08:29 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,752
Yes (well, not iexplore.exe itself, but the components of IE that implement hosting in other applications).
Reply With Quote
  #11  
Old 03-04-2014, 09:09 AM
PJMiller PJMiller is online now
Registered User
 
Join Date: 02-06-2014
Posts: 42
I installed Internet Exploiter 11.

SVG display started working, no other changes.

Name:  Success.png
Views: 122
Size:  112.8 KB

This is a graph generated by Matlab, but the graphs from Inkscape and Graphviz also work.

Thank you.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 03:21 PM.


Copyright 1999-2019 Kinook Software, Inc.