Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 03-11-2008, 09:46 AM
Rogier Rogier is online now
Registered User
 
Join Date: 09-09-2004
Location: the Netherlands
Posts: 40
Secure FTP doesn't support SSH(2)?

I'm creating a .bld that automatically uploads some stuff to two different servers, using VBP's built-in FTP command. I want this to be secure (mainly to avoid readable login info being transferred). One server supports SSL, and if I choose that option in the Security tab it works fine.

The other server however supports SSH (and not SSL/TLS/etc) as security protocol. If I log in there with a 3rd party FTP client like FileZilla, I have to choose the option "SFTP using SSH2" and everything works fine then. However, VBP does not seem to support this. I've tried each available Security option but it can't login.

Am I overlooking something, or is this just a no-go?
Reply With Quote
  #2  
Old 03-11-2008, 10:03 AM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,750
SFTP is not currently supported by the FTP action (adding support is on our list), but for now you can use an SSH tunnel to encrypt the FTP authentication.
http://www.visualbuild.com/Manual/plinktunnelaction.htm
http://www.visualbuild.com/Manual/networksample.htm
http://www.kinook.com/blog/?p=6
Reply With Quote
  #3  
Old 03-11-2008, 10:05 AM
Rogier Rogier is online now
Registered User
 
Join Date: 09-09-2004
Location: the Netherlands
Posts: 40
Ah great, thanks! Good to hear you will be adding SFTP, and the workaround looks promising. Will experiment with it right away!
Reply With Quote
  #4  
Old 05-01-2008, 03:12 PM
Rogier Rogier is online now
Registered User
 
Join Date: 09-09-2004
Location: the Netherlands
Posts: 40
Following up on your suggestion, when I originally tried it I couldn't get it to work. Now trying again, using the network.bld sample. The thing is: I got Putty set up correctly (at least I think so, I managed to connect and login once to accept the fingerprints). Plink works, window says: using username <myname>

But then the FTP step, which is set to connect to localhost at the local port which I configured in the plink step to be forwarded to myserver:22, immediately cancels with this message:

"Error connecting to FTP server: Unable to resynchronize with server"

Am I doing something wrong? Passive mode is enabled, and I filled in the correct username and password at both the FTP and Plink steps. If I open a telnet session manually (connecting to localhost localport) while the plink window is still open, I get a response:

"SSH-2.0-OpenSSH_3.8.1p1 Debian-8.sarge.6"

So there obviously is some sort of connection..?

Last edited by Rogier; 05-01-2008 at 03:14 PM.
Reply With Quote
  #5  
Old 05-01-2008, 03:35 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,750
What kind of FTP server is it? Are you able to connect to localhost (and the local tunnel port) with FileZilla? Please ZIP and send to support@kinook.com:
1) The info from Help | About | Install Info
2) The .bld file
3) A build log file with the Logging field on the Transfer tab of the FTP action Logging field set to 'All + hex dump'

Thanks.
Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 11:17 PM.


Copyright 1999-2019 Kinook Software, Inc.