Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] General Discussion

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 11-23-2021, 01:24 PM
teognost teognost is online now
Registered User
 
Join Date: 05-25-2004
Location: Prague,Czech Republic
Posts: 188
Exclamation Wscript.Echo not working

Hi
I have a Run Script step (VBScript) inside my Visual Build project which contains:
Wscript.Echo "Test message"
When i start it in Visual Build the message is shown in the log.
But when I run it command line like this:
"c:\Program Files\VisBuildPro9\VisBuildCmd.exe" /b "c:\Program Files\VisBuildPro9\Test.bld"
the message is now shown in the log.
Any idea why and how can I make it visible ?
Reply With Quote
  #2  
Old 11-23-2021, 09:24 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,837
It works in my tests. Using the attached project, and building with

"C:\Program Files\VisBuildPro10\VisBuildCmd.exe" D:\temp\test.bld

it outputs

11/23/2021 7:22:54 PM: Starting Build: 'D:\temp\test.bld'
11/23/2021 7:22:54 PM: Building project step 1 - Project steps...
11/23/2021 7:22:54 PM: Building project step 2 - Run Script...
Test message
11/23/2021 7:22:54 PM: Build successfully completed (elapsed = 00:00:00).

Please send the info from

https://www.kinook.com/Forum/showthread.php?t=3044
Attached Files
File Type: bld test.bld (464 Bytes, 5 views)
Reply With Quote
  #3  
Old 11-24-2021, 10:46 AM
teognost teognost is online now
Registered User
 
Join Date: 05-25-2004
Location: Prague,Czech Republic
Posts: 188
I cannot open\run the test project as I have VisBuildCmd (x64), Version 9.7.0.1 and yours is a newer version.
Would be possible to give me the same test project but version 9.7?
Reply With Quote
  #4  
Old 11-24-2021, 12:34 PM
teognost teognost is online now
Registered User
 
Join Date: 05-25-2004
Location: Prague,Czech Republic
Posts: 188
I tried my test project on other machine -wscript.echo worked ,i had the test message in the log.Any idea why on that specific machine the command does not work?Could be some Visual Build setting causing this issue?
Reply With Quote
  #5  
Old 11-24-2021, 02:23 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,837
Open the .bld file in a text editor and change the version to 9.

I don't know, send the info in the link above and we'll see.
Reply With Quote
  #6  
Old 11-24-2021, 03:07 PM
teognost teognost is online now
Registered User
 
Join Date: 05-25-2004
Location: Prague,Czech Republic
Posts: 188
I ran it and the echo did not work:
:\Program Files\VisBuildPro9>"c:\Program Files\VisBuildPro9\VisBuildCmd.exe" "c:\Program Files\VisBuildPro9\Test.bld"

VisBuildCmd (x64), Version 9.7.0.1

11/24/2021 9:04:54 PM: Starting Build: 'c:\Program Files\VisBuildPro9\Test.bld'
11/24/2021 9:04:54 PM: Building project step 'Project steps'...
11/24/2021 9:04:54 PM: Building project step 'Run Script'...
11/24/2021 9:04:54 PM: Build successfully completed (elapsed = 00:00:00).

The link you provided is for Ultra Recall,could you please tell me which one is for Visual Build...
Reply With Quote
  #7  
Old 11-24-2021, 03:08 PM
teognost teognost is online now
Registered User
 
Join Date: 05-25-2004
Location: Prague,Czech Republic
Posts: 188
I found it:
https://www.kinook.com/Forum/showthread.php?t=3044
I will send the info required here
Reply With Quote
  #8  
Old 11-25-2021, 09:50 PM
kinook kinook is online now
Administrator
 
Join Date: 03-06-2001
Location: Colorado
Posts: 5,837
In the .config file, set the LogLevel to 3, or in the UI, set Tools | Application Options | Logging (More) | Log Level to Detailed.
Reply With Quote
  #9  
Old 11-26-2021, 06:45 AM
teognost teognost is online now
Registered User
 
Join Date: 05-25-2004
Location: Prague,Czech Republic
Posts: 188
Thanks,this change in log level to detailed solved the issue
Reply With Quote
Reply

Tags
vbscript

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 01:28 AM.


Copyright 1999-2021 Kinook Software, Inc.