Kinook Software Forums

Go Back   Kinook Software Forums > Visual Build Professional > [VBP] Third Party Tools

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 01-08-2008, 09:30 AM
dheller dheller is online now
Registered User
 
Join Date: 08-07-2007
Location: New Castle, DE
Posts: 14
Script to Increment InstallShield Build Number Fails

I just upgraded from InstallShield 12 to InstallShield 2008 and changed my project from MSI Basic to InstallScript MSI and now when I try to execute the VB Script to increment the InstallShield Build number, the error "File does do exist" is always generated. This works if it try it with my Basic MSI project, but always fails with the InstallScript MSI project

' create the InstallShield Developer automation object

Set objInst = CreateObject("ISWiAuto14.ISWiProject")
' for InstallShield 2008 (use SAAuto14.ISWiProject for standalone)

' use "ISWiAuto12.ISWiProject" for InstallShield 12 (use SAAuto12.ISWiProject for standalone)




' open the project file

objInst.OpenProject "C:\My Setups\TRIOS\TRIOS1.ism"

' this code demonstrates incrementing the revision version number

' retrieve and split the ProductVersion

verArr = Split(objInst.ProductVersion, ".")

' increment last field

verArr(UBound(verArr)) = CStr(verArr(UBound(verArr)) + 1)

' update the project

objInst.ProductVersion = Join(verArr, ".")

objInst.SaveProject

objInst.CloseProject
Reply With Quote
 

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 07:30 AM.


Copyright 1999-2022 Kinook Software, Inc.